Hardware Requirements

What can Row64 run with?

Update as Row64 v1.2

Row64 is obsessed with getting the best data performance out of your hardware. For that reason, we push the limit of hardware capability and drivers. Once you get Row64, the first thing you should do is update to the latest graphics card drivers to get the best performance.

If your goal is to have record-breaking performance, we recommend getting some newer hardware that supports Vulkan 1.2. You can get a machine that does this for under $1,200 and it would be worth it if you do data work professionally.

However, we’re also going the extra mile to get Row64 working on older / diverse hardware. Here’s our current status:

Vulkan 1.2 Windows: Ideal setup - with raytracing (Nvidia cards since 2016, recent AMD + Intel Arc)
Vulkan 1.1 Windows: Good Setup - no raytracing (Nvidia since 2012, AMD since 2011 + Intel since 2015)
DirectX 11: Reasonable setup - No raytracing and not as performant. Support for most Windows machines back to Vista.
Linux: Work in Progress - early version running on Ubuntu.
Apple GPU: Under investigation. Row64 development started on the Mac, and the founders are Mac users. However, we’ve had so many Windows user requests that we started with this group first.

Row64 will automatically detect the best graphics your computer can support. If your computer supports Vulkan 1.2 it will use that, if not it checks for Vulkan 1.1. If Vulkan is not supported or no drivers are installed it will fall back to DirectX11. DirectX11 is approximately 30% slower at display than Vulkan but it is still lightning fast GPU drawing.

Row64 will push your hardware and GPU to the absolute limit. The most advanced features in Row64 (raytracing) will only run on GPUs that support it. However, in hardware limited systems, Row64 will just turn off those features. For example, If your computer doesn’t support Vulkan 1.2, Row64 will turn off the raytracing features which include raytraced charting and geo-analysis.

With Vulkan 1.1 and DX11, all the spreadsheet, notebook, and Python features work. If you don’t have Vulkan 1.2, Vulkan 1.1, DX11, or are using hardware we haven’t released installers for yet, Row64 will prompt you to request an installer. Please vote for your installer, we will prioritize based on requests.

It’s important to get the latest drivers for your graphics card, Row64 may not run optimally. for your hardware. Below are some tips on getting the latest graphics drivers.

When downloading and running the installer, remember to pay attention to the Diagnostic Report that will determine exactly which dependencies are needed to run Row64, and if your machine requires updated drivers.

If you are running Vulkan but would like to experiment running with running DirectX you can run it from the command line. Row64 will install in your “C:\Program Files\Row64”. Find the version you want to test and run the path to the exe in the command line with the -dx11 flag. Here’s an example:

                               "C:\Program Files\Row64\Row64_V1_2\Row64.exe" -dx11

After installation, you can re-run the hardware diagnostics for Row64 from the “?” in the top menu bar of the application.


What To Do If You Have Installation Problems

If you have an installation problem and want to discuss them in this forum, please copy and paste the Diagnostic Report you get when you first install Row64:

This will help discussions and support on the exact issue.

Installation discussion and troubleshooting are further detailed in our Install Troubleshooting thread.


Getting the Right Graphics Card Driver

It’s important to have the latest driver for your card.
Here is an example of NVIDIA’s driver info that shows compatibility:

Visit the official Vulkan webpage to determine whether your GPU card can support Vulkan 1.1 or 1.2:

[Possible Video here]

You may also be considering visiting the official Khronos webpage for additional Vulkan-GPU support and news about the latest drivers:


Download Drivers

Below are links to the driver support for different GPUs:

NVIDIA ~~~ (Choose the exact version that matches your card model)

AMD ~~~ (Please download the latest version)

INTEL ~~~ (You may need to find Vulkan API, specific drivers)

Intel support can be tricky at times so here are additional links that may help resolve driver installation issues for Intel:

Adobe Guide:
Manually Install Intel Drivers on Windows 10

Youtube Guide:
How To Properly Update & Install The Latest Intel HD Graphics Driver For Windows 10, 8, 7 - 2021

DELL
Drivers & Downloads | Dell US


Recommended Optimal Row64 Environment

  • Latest Vulkan-Compatible Drivers (NVIDIA, AMD, INTEL)
  • At least Intel i7 and newer
  • At least 4 GB RAM
  • Windows 10

On Windows, Row64 uses Vulkan for newer cards and DirectX 11 for older cards: